用鼠标与指尖
让互联网更加有趣

易语言源码-腾讯云CDN缓存刷新

易语言源码-腾讯云CDN缓存刷新-小伟博客各位站长在使用CDN内容分发网络服务时,每当我们修改了网站文件都要在CDN平台去刷新缓存,这样很麻烦。

所以我自己利用腾讯云提供的API开发了易语言版本的软件,同时在这提供源代码供大家学习使用。

易语言编写教程

首先新建一个易语言程序源码

然后添加 四个编辑框/三个单选框/一个按钮:

易语言源码-腾讯云CDN缓存刷新-小伟博客

然后双击窗口写代码:

.版本 2
.支持库 shell

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 data, 文本型


data = 读配置项 (取特定目录 (1) + “\tcloud.ini”, “data”, “key”, )
.如果真 (data ≠ “”)
    编辑框2.内容 = 读配置项 (取特定目录 (1) + “\tcloud.ini”, “data”, “key”, )
    编辑框1.内容 = 读配置项 (取特定目录 (1) + “\tcloud.ini”, “data”, “id”, )
.如果真结束


.子程序 _编辑框3_鼠标左键被放开, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

.如果真 (编辑框3.内容 = “要刷新的URL,一行一个”)
    编辑框3.内容 = “”
.如果真结束


.子程序 _按钮1_被单击
.局部变量 url, 文本型, , "0"
.局部变量 get_url, 文本型
.局部变量 计次, 整数型
.局部变量 data, 文本型
.局部变量 json, 类_json

url = 分割文本 (删全部空 (编辑框3.内容 + #换行符), #换行符, )
.如果真 (取数组成员数 (url) < 1)
    返回 ()
.如果真结束

.计次循环首 (取数组成员数 (url), 计次)
    .如果 (寻找文本 (url [计次], “http”, , 真) ≠ -1)
        .如果真 (单选框1.选中 = 真)
            get_url = “https://api.mlwei.com/tcloud/api/cdn/RefreshCdnUrl.php?key=” + 编辑框2.内容 + “&id=” + 编辑框1.内容 + “&url=” + url [计次]
        .如果真结束
        .如果真 (单选框2.选中 = 真)
            get_url = “https://api.mlwei.com/tcloud/api/cdn/RefreshCdnDir.php?key=” + 编辑框2.内容 + “&id=” + 编辑框1.内容 + “&type=1&url=” + url [计次]
        .如果真结束
        .如果真 (单选框3.选中 = 真)
            get_url = “https://api.mlwei.com/tcloud/api/cdn/RefreshCdnDir.php?key=” + 编辑框2.内容 + “&id=” + 编辑框1.内容 + “&type=2&url=” + url [计次]
        .如果真结束

        data = 到文本 (网页_访问 (get_url, , , , , , , , , , ))
        json.解析 (data)
        .如果 (json.取通用属性 (“codeDesc”, ) = “Success”)
            编辑框4.加入文本 (url [计次] + “  【刷新成功.】” + #换行符)
        .否则
            编辑框4.加入文本 (url [计次] + “  【刷新失败.】” + #换行符)
        .如果结束

    .否则
        编辑框4.加入文本 (url [计次] + “  【域名格式错误.】” + #换行符)
    .如果结束

.计次循环尾 ()

写配置项 (取特定目录 (1) + “\tcloud.ini”, “data”, “id”, 编辑框1.内容)
写配置项 (取特定目录 (1) + “\tcloud.ini”, “data”, “key”, 编辑框2.内容)

具体效果是这样的:

易语言源码-腾讯云CDN缓存刷新-小伟博客

写好之后检查无误运行测试后编译即可

看不懂的可以下载我写好的易语言源码自己研究

易语言源码下载:腾讯云CDN缓存刷新易语言源码 访问密码:cd43

支付宝扫码打赏 微信扫码打赏

如果文章对你有帮助,欢迎点击上方按钮打赏作者

未经允许不得转载:小伟博客 » 易语言源码-腾讯云CDN缓存刷新

分享到:更多 ()

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

小伟博客 · 给你感兴趣的内容

联系我们官方交流群